Browser Requirements

Health Plans: 

  • NaviNet Basics

Workflow: 

  • General

To access NaviNet, use any of the following browsers. NaviNet is designed to work properly on these browsers, but you might notice some slight differences in the displays.

To ensure data security, NaviNet requires that all web browsers use the Transport Layer Security (TLS) 1.2 protocol. Contact your IT department if you have any questions.

Platform

Windows® (all Microsoft®-supported desktop operating systems, unless otherwise noted)

Macintosh® operating systems Linux® operating systems
Browsers
  • Internet Explorer® 11 on  Windows 8.1 and Windows 10
  • Microsoft Edge™ (latest version) on Windows 10
  • Mozilla Firefox® (latest version)
  • Google Chrome™ (latest version)
  • Safari® 14 on macOS® 11 (Big Sur)
  • Safari 13 on macOS 10.15 (Catalina)
  • Mozilla Firefox (latest version)
  • Google Chrome (latest version)

Mozilla Firefox (latest version) 

Some workflows hosted by health plans or health-plan-approved vendors may only be available via Microsoft Internet Explorer. For these workflows, you will be prompted to use Internet Explorer.

Refer to the Optimizing Your Browser guide for detailed instructions on configuring your browser to work with NaviNet.

Related Topics

Rate this topic: 

Average: 3.2 (36 votes)